Forum Katalogu Ciekawych Stron Strona Główna  Forum Katalogu Ciekawych Stron Strona Główna  
 
FAQ  FAQ   Szukaj  Szukaj   Użytkownicy  Użytkownicy   Ranking systemów  Ranking systemów   Grupy  Grupy  
 
Rejestracja  ::  Zaloguj Zaloguj się, by sprawdzić wiadomości
 
Forum Katalogu Ciekawych Stron Strona Główna » Grafika » Lightbox - ciekawe wyświetlanie zdjęć na stronach

Napisz nowy temat  Odpowiedz do tematu Idź do strony Poprzedni  1, 2, 3, 4, 5, 6, 7, 8  Następny
 Lightbox - ciekawe wyświetlanie zdjęć na stronach « Zobacz poprzedni temat :: Zobacz następny temat » 
Autor Wiadomość
voy-tech
PostWysłany: 17 Lut 2008, 20:17    Temat postu: Odpowiedz z cytatem Zacytuj zaznaczone

Gaduła
Gaduła

Dołączył: 31 Sie 2007
Posty: 286

Ostrzeżeń: 1

Kuklik12 zmień tę część kodu na taką:
Kod:

#outerImageContainer{
   position: relative;
   background-color: #fff;
   width: 250px;
   height: 250px;
   margin: -60px auto 0 auto;
   }

Zmieniona ostatnia linijka.


Ostatnio zmieniony przez voy-tech dnia 22 Lut 2008, 16:45, w całości zmieniany 1 raz
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość
KCS
Wysłany:     Temat postu: Reklama w KCS







Pozycjonusz.pl - Reklama Twojej firmy !
Oferujemy szereg usług reklamujących Państwa witrynę w wyszukiwarce Google. Dzięki nam strona zdobędzie wartościowe linki i poprawi swoją pozycję w wynikach wyszukiwania !

Powrót do góry
rafzyh
PostWysłany: 22 Lut 2008, 13:46    Temat postu: maly problem Odpowiedz z cytatem Zacytuj zaznaczone

Nowicjusz
Nowicjusz

Dołączył: 22 Lut 2008
Posty: 4

Skąd: ?ód?

witam
dotyczy mojej strony
http://www.zych.republika.pl/foto2.html

korzystam z lightboxa i irytowalo mnie to ze trzeba czekac na zaladowanie strony w calosci. postanowilem wiec dodac "klepsydre" zaczekaj az sie zaladuje dopoki strona sie nie wgra w calosci.
zmiana jest w <body>

Kod:
<BODY onload="initLightbox() ; init()">
<div id="loading" style="position:absolute; width:100%; text-align:center; top:300px;"><img src="images/wait_load.gif" alt="Zaczekaj" border=0></div>
<script type="text/javascript>
var ld=(document.all);
var ns4=document.layers;
var ns6=document.getElementById&&!document.all;
var ie4=document.all;
if (ns4)
   ld=document.loading;
else if (ns6)
   ld=document.getElementById("loading").style;
else if (ie4)
   ld=document.all.loading.style;
function init()
{
if(ns4){ld.visibility="hidden";}
else if (ns6||ie4) ld.display="none";
}
</script>


skrypt jest ze strony http://www.reconn.us/content/view/37/47/
no i wszystko byloby ok gdyby nie internet explorer 7.0
po zaladowaniu galerii i wybraniu zdjecia odpala sie lightbox ale na zdjeciu zostaje migajaca "klepsydra"
w firefoxie wszystko jest ok
macie moze jakis pomysly co z tym zrobic ?
pozdrawiam
rafal


Ostatnio zmieniony przez rafzyh dnia 25 Lut 2008, 08:05, w całości zmieniany 1 raz
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość Odwiedź stronę autora
kristooki
PostWysłany: 22 Lut 2008, 15:57    Temat postu: Odpowiedz z cytatem Zacytuj zaznaczone

Wszechwiedzący
Wszechwiedzący

Dołączył: 08 Lut 2006
Posty: 924

Skąd: Kraków

a wystarczy użyć CSS do wyświetlania galerii Wink zapraszam tutaj -> Koncert Łzy

kliknij w obrazek zanim strona się załaduję a zrozumiesz jak to działa Wink
_________________
KRISTOOKI

Podczas zamawiania pakietu startowego wpisz [/url] | kod polecajacy Mobile Vikings i odbierz 19 zl za darmo.
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość Odwiedź stronę autora
rafzyh
PostWysłany: 22 Lut 2008, 16:21    Temat postu: Odpowiedz z cytatem Zacytuj zaznaczone

Nowicjusz
Nowicjusz

Dołączył: 22 Lut 2008
Posty: 4

Skąd: ?ód?

no wlasnie o to mi chodzi zeby to tak nie wygladalo jak na podanej przez Ciebie stronie Sad
jest dokladnie tak jak u mnie przed modyfikacja, jak sie nie zaladuje cala to po kliknieciu w fotke odpala w nowym oknie.

moge to zrobic w stylu nie kijem go to palka, czyli zamienic gifa klepsydry przy ladowaniu na gifa 1x1 pixel i bedzie ok ale nie o to mi chodzi
pozdrawiam
rafal
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość Odwiedź stronę autora
kristooki
PostWysłany: 22 Lut 2008, 18:54    Temat postu: Odpowiedz z cytatem Zacytuj zaznaczone

Wszechwiedzący
Wszechwiedzący

Dołączył: 08 Lut 2006
Posty: 924

Skąd: Kraków

rafzyh napisał:
jest dokladnie tak jak u mnie przed modyfikacja, jak sie nie zaladuje cala to po kliknieciu w fotke odpala w nowym oknie.

otóż właśnie nie Smile ładuje się html + js i już dział lightbox, a dopiero potem ładują się miniaturki.
_________________
KRISTOOKI

Podczas zamawiania pakietu startowego wpisz [/url] | kod polecajacy Mobile Vikings i odbierz 19 zl za darmo.
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość Odwiedź stronę autora
rafzyh
PostWysłany: 22 Lut 2008, 19:10    Temat postu: Odpowiedz z cytatem Zacytuj zaznaczone

Nowicjusz
Nowicjusz

Dołączył: 22 Lut 2008
Posty: 4

Skąd: ?ód?

no niestety nie dziala na pewno, byc moze przy szybkim laczu jest to niezauwazalne ze wzgledu na mala ilosc danych do zaladowania, ale radze sprawdzic na wolniejszym laczu lub przy jednoczesnym podladowywaniu czegos np z ftp-a
i prosze najpierw wykasowac cache
pzdr
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość Odwiedź stronę autora
kristooki
PostWysłany: 22 Lut 2008, 19:47    Temat postu: Odpowiedz z cytatem Zacytuj zaznaczone

Wszechwiedzący
Wszechwiedzący

Dołączył: 08 Lut 2006
Posty: 924

Skąd: Kraków

moje rozwiązanie polega na umieszczeniu miniaturek jako tła linku. Może w przypadku tej strony która podałem to nie zadziałało, gdyż nie ma tam zbyt wielu miniaturek, ale gdybym powiększył ich ilość lub zastosował tak duże miniaturki jak u Ciebie - sztuczka udałaby się Smile

Dlaczego? Javascript uruchamiany jest po załadowaniu dokumentu - w tym przypadku strony internetowej (plik htm + js).

Tło CSS linków (czyli nasze miniaturki) doładowywane są później (już po zniknięciu paska ładowania strony).

Ponieważ to CSS, strona w momencie załadowania ma swój układ - widać białe obramowania "miniaturek" które tak na prawdę są ostylowanymi linkami tekstowymi.

Jeśli tylko załaduje nam się plik html + js lightboxa wszystko zadziała poprawnie Smile

Przykład który podałem może nie jest najlepszy - ale spróbuj zrobić to ze swoimi miniaturkami (większymi od moich) a zobaczysz że zadziała Wink

Pamiętaj też żeby nie doładowywać ciężkich skryptów na strony galerii.
_________________
KRISTOOKI

Podczas zamawiania pakietu startowego wpisz [/url] | kod polecajacy Mobile Vikings i odbierz 19 zl za darmo.
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość Odwiedź stronę autora
rafzyh
PostWysłany: 22 Lut 2008, 20:06    Temat postu: Odpowiedz z cytatem Zacytuj zaznaczone

Nowicjusz
Nowicjusz

Dołączył: 22 Lut 2008
Posty: 4

Skąd: ?ód?

tak, czytalem o takim rozwiazaniu, ale nie w tym rzecz Smile
moglbym to zaladowac jako tlo lub jako ukryte obrazy w css-ie
podoba mi sie ten baner prosze czekac etc, takie moje widzimisie Smile
i nadal mam problem z wyswietlaniem tego na internet explorerze niestety.
zeby to chodzilo tak jak na firefoxie to bylbym w 7 niebie
dzieki za sugestie i pozdrawiam
rafal
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość Odwiedź stronę autora
reig
PostWysłany: 25 Lut 2008, 13:46    Temat postu: Odpowiedz z cytatem Zacytuj zaznaczone

Nowicjusz
Nowicjusz

Dołączył: 14 Sty 2008
Posty: 4


voy-tech napisał:
Kuklik12 zmień tę część kodu na taką:
Kod:

#outerImageContainer{
   position: relative;
   background-color: #fff;
   width: 250px;
   height: 250px;
   margin: -60px auto 0 auto;
   }

Zmieniona ostatnia linijka.
dzieki, mnie tez o to chodzilo.
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość
reig
PostWysłany: 26 Lut 2008, 13:20    Temat postu: Re: maly problem Odpowiedz z cytatem Zacytuj zaznaczone

Nowicjusz
Nowicjusz

Dołączył: 14 Sty 2008
Posty: 4


rafzyh napisał:
witam
dotyczy mojej strony
http://www.zych.republika.pl/foto2.html

korzystam z lightboxa i irytowalo mnie to ze trzeba czekac na zaladowanie strony w calosci. postanowilem wiec dodac "klepsydre" zaczekaj az sie zaladuje dopoki strona sie nie wgra w calosci.
zmiana jest w <body>

Kod:
<BODY onload="initLightbox() ; init()">
<div id="loading" style="position:absolute; width:100%; text-align:center; top:300px;"><img src="images/wait_load.gif" alt="Zaczekaj" border=0></div>
<script type="text/javascript>
var ld=(document.all);
var ns4=document.layers;
var ns6=document.getElementById&&!document.all;
var ie4=document.all;
if (ns4)
   ld=document.loading;
else if (ns6)
   ld=document.getElementById("loading").style;
else if (ie4)
   ld=document.all.loading.style;
function init()
{
if(ns4){ld.visibility="hidden";}
else if (ns6||ie4) ld.display="none";
}
</script>


skrypt jest ze strony http://www.reconn.us/content/view/37/47/
no i wszystko byloby ok gdyby nie internet explorer 7.0
po zaladowaniu galerii i wybraniu zdjecia odpala sie lightbox ale na zdjeciu zostaje migajaca "klepsydra"
w firefoxie wszystko jest ok
macie moze jakis pomysly co z tym zrobic ?
pozdrawiam
rafal

wyrzuc z body "initLightbox()" i bedzie dobrze. patrzylem u siebie i tez mi w IE7 nie dzialalo, tzn. tam w ogole nie znokalo, nawet po zaladowaniu, a w Firefoxie bylo dobrze. Wystarczy
Kod:
<body onLoad="init()" >
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość
grafit
PostWysłany: 03 Mar 2008, 13:10    Temat postu: Bardzo prosze o podpowiedż Odpowiedz z cytatem Zacytuj zaznaczone

Nowicjusz
Nowicjusz

Dołączył: 03 Mar 2008
Posty: 2


Chcialbymużyć LightBoxa ale........
coś mi nie wychodzi Sad .
Wszystkie pliki ze skryptem mam w folderze gdzie jest
index.galeria .
Na próbe wpisalem tak:

<?xml version="1.0" encoding="ISO-8859-2"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN"
"http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="pl">
<head>
<style type="text/css">
body {background-color:red;}
<meta http-equiv="Content-type" content="text/html; charset=iso-8859-2" />
<title>Galeria</title>
<script type="text/javascript" src="lightbox.js"></script>
<link rel="stylesheet" href="lightbox.css" type="text/css" media="screen" />

</style>

</head>
<body>
<a href="aaaa.jpg" rel="lightbox" title="pierwszee">
pierwsze</a>
<a href="bbbb.jpg" rel="lightbox" title="drugiee">
drugie
</a>
<a href="cccc.jpg" rel="lightbox" title="trzeciee">
trzecie</a>
<p>
Moja pierwsza strona WWW!
</p>

</body>
</html>
Otwieraja się obrazki ale
zwyczajnie,bez żadnej animacjii Sad
gdzie robię błąd? czego tu brakuje?
Dziękuję
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość
max
PostWysłany: 03 Mar 2008, 14:52    Temat postu: Odpowiedz z cytatem Zacytuj zaznaczone

Znawca
Znawca

Dołączył: 16 Cze 2005
Posty: 738


A może kod byś poprawnie zapisał
Kod:

<meta http-equiv="Content-type" content="text/html; charset=iso-8859-2" />
<title>Galeria</title>
<style type="text/css">
body {background-color:red;}
</style>
<script type="text/javascript" src="lightbox.js"></script>
<link rel="stylesheet" href="lightbox.css" type="text/css" media="screen" />
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość
grafit
PostWysłany: 03 Mar 2008, 23:48    Temat postu: Dziękuję Odpowiedz z cytatem Zacytuj zaznaczone

Nowicjusz
Nowicjusz

Dołączył: 03 Mar 2008
Posty: 2


Dziękuję za pomoc .
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość
beleth
PostWysłany: 18 Mar 2008, 14:58    Temat postu: Bardzo prosze o odpowiedz... Odpowiedz z cytatem Zacytuj zaznaczone

Nowicjusz
Nowicjusz

Dołączył: 18 Mar 2008
Posty: 3

Skąd: ?ory

Witam!
Probuje wrzucic lightboxa otwieranego z flasha... mecze sie juz 5 godzine i nie moge ruszyc z miejsca, nic nie dziala...
Czy moglbym prosic kogos, kto juz to robil badz wie jak to zrobic o podanie DOKLADNEJ instrukcji? Przeszperalem juz chyba z tysiac stron www, probowalem wszystkiego chyba i nie ma szans.

www.beleth.c0.pl galeria znajduje sie w osobnym swf'ie.

Prosze o pomoc i z gory dziekuje Wink
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość Odwiedź stronę autora Numer GG
dominorex
PostWysłany: 20 Mar 2008, 14:19    Temat postu: Odpowiedz z cytatem Zacytuj zaznaczone

Nowicjusz
Nowicjusz

Dołączył: 20 Mar 2008
Posty: 4


Witam wszytstkich

Jak powinien wygladac kod w lightbox zeby pojawil sie znak przewijania nastepnego zdjecia znaczek >


Na pojawienie sie jednego zdjecia podalem kod:

<a href="images/image-1.jpg"title="zdjecie ciekawe" rel="lightbox">Oczko wodne</a></h2>


p.s. przegladalem pliki lightbox 2.0 ale nic w kodzie nieznalazlem

pozdrawiam
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość
Wyświetl posty z ostatnich:   
Napisz nowy temat  Odpowiedz do tematu Idź do strony Poprzedni  1, 2, 3, 4, 5, 6, 7, 8  Następny Strona 7 z 8


Forum Katalogu Ciekawych Stron Strona Główna » Grafika » Lightbox - ciekawe wyświetlanie zdjęć na stronach
Skocz do:  



Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach


katalog stron | forum
Powered by phpBB © 2005 phpBB Group